Ford B-Max Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
212 Posts
"Do not operate the washers when the washer reservoir is empty! This may cause the washer pump to overheat" then to get fried...

Source: WINDSHIELD WASHERS at page 45th of the 20.26 MB ENUSA_CG3573_BMX_og_201308.pdf
 

·
Registered
Joined
·
1,102 Posts
I have unblocked jets with a fine sewing needle on many occasions, but if it's an airlock, may need to just take the tubes off and run the washers.

Of course, Ice can block the jets, though the washer fluid shoyud contain anti freezing agent. Even so, Ice on the top can still block, though surface ice can be cleared with warm water.
 

·
Registered
Joined
·
1,102 Posts
vdragoslav said:
"Do not operate the washers when the washer reservoir is empty! This may cause the washer pump to overheat" then to get fried...

Source: WINDSHIELD WASHERS at page 45th of the 20.26 MB ENUSA_CG3573_BMX_og_201308.pdf
If that was the case, you would not hear the motor run.
 

·
Registered
Joined
·
212 Posts
So there's a single pump (motor) for both front and rear windows, or each has its own one? :-? If it's the second scenario, how one can conclude that it's the motor for the windshield that he's hearing?Edited by: vdragoslav
 

·
Registered
Joined
·
1,102 Posts
vdragoslav said:
So there's a single pump (motor) for both front and rear windows, or each has its own one? :-? If it's the second scenario, how one can conclude that it's the motor for the windshield that he's hearing?
I'm not sure if there is one motor or two. Either way, what I am saying is that if you operate the washer and hear no sound then the motor has burned out. If you are lucky, it may have just blown the fuse.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #9 ·
Thank you all for your interest (replies). What I do know about the screen washer system for Ford B Max is that there is only ONE washer pump. The fault is as follows ; I ran out of washer liquid, refilled the washer reservoir, tried the front washer but no liquid coming on front windscreen tried the rear washer, that was working. My conclusion was that if there is only one pump and the rear windscreen is only working then may be the single pump dose both screens and the part of the pump that operates the front screen has gone faulty. ????Thanks Les V.
 

·
Registered
Joined
·
132 Posts
Hi again Les, your findings would seem to point to there being a air lock OR blockage in the pipe connected to the front washers and as mentioned by cianpars, could possibly be due to ice. Try unblocking the jets with a fine needle or wire, then disconnect the washer pipes and blow through them, this has often worked for me over the years.
 

·
Registered
Joined
·
315 Posts
My front washers once stopped working, and it was the nearside bonnet hinge was nipping the pipe.
 

·
Registered
Joined
·
212 Posts
Cars, cars, cars...
"try using the washer with your
bonnet
up (open) if it works ok there is a good chance the
pipe
is being '
nipped
' around the
bonnet hinge
when you close the
bonnet
"http://www.astraownersnetwork.co.uk/archive/index.php/t-108962.html


"Drivers side coming out of the wing and onto the
bonnet
, a
nipped pipe
here can stop the washers from working. ... Guess what it was....the
pipe
was
nipped
at the
bonnet hinge
, I put it right for him and washers working again."
http://www.jaguarforum.com/archive/index.php/t-78299.html
 

·
Registered
Joined
·
120 Posts
My front screen washer is somewhat temperamental. Every now and again you press and nowt happens, even though I always check and top up where necessary. When it does work, its less a positive stream of fluid than a reluctant and rather limp spray. I reckon there's a bad contact somewhere.

Rear washer works without fail.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #14 ·
Re my front windscreen wash still not functioning after various suggestions by members. I urgently needed my front screen to function so I had to call into a garage to look at it and after the front and rear pipes from the pump were reversed the front screen worked and rear didn`t. I have to remember to operate the rear screen switch for the front washers to function. What does this indicate. Is there a fuse in the front circuity or could it be the front switch faulty?
 

·
Registered
Joined
·
1,102 Posts
Yeah. put antifreeze in the water and see what it does to your paintwork.
 

·
Registered
Joined
·
1,102 Posts
Hadrian1 said:
I think (I hope) he meant a dedicated screen wash anti freeze :)
You would hope so, but i know a few who have done it :)
 
1 - 18 of 18 Posts
Top