Ford B-Max Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi All
I've got an 18 plate Titanium 1.0 EcoBoost, 5 speed manual. In the last couple of weeks the engine has developed a judder and rattle whilst driving, especially when going from a cold start. I can't work out what it could be. It's also become sluggish in acceleration. Up until the issue, it's been a cracking drive. Can anyone in the forum help. Ta very much.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
sounds like a fuelling issue. what fuel are you using, and how long has it been in there?
Hi Gremlin thanks for replying. I use the car daily. I'm only putting premium petrol in (not that I can afford it 🙄) and monthly a bottle of clean drive. I filled up last week.
A mechanic mate said it could be the spark plugs.
But I'm not sure...
 

·
Registered
Joined
·
482 Posts
Sounds like spark plug/coil top issue to me too. Plugs ain’t cheap, they’re a racing plug!!
Diagnostics might pinpoint it.
I agree the next step is obd diagnostics, probably need to collect the live data, not just the stored codes.
the reason I suggested fuel first; modern fuels can absorb water from the air, and then separate leaving water in the fuel.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Sounds like spark plug/coil top issue to me too. Plugs ain’t cheap, they’re a racing plug!!
Diagnostics might pinpoint it.
Many thanks for the feedback.
I made a price enquiry with my local Ford dealer about the spark plugs... £65 for three plugs! Anyway I called a local auto parts shop. Got some Bosch plugs for 12 quid each.
At the same time I picked up some more 5w20 oil for the B-Max.
That's when I discovered the issue... I got through two 1 litre bottles before the oil dip stick started showing the oil!!
When I bought the car back in June this year it had done 16000 miles. I've done 25300 as of today. So 9000 -ish miles.
I topped the oil up when I first bought the car
I didn't think the oil would go down that quick!
Plus no oil leaks noticed on the ground where I've parked overnight.
ANYWAY, long story short. It was the low oil levels causing the issue. Engine knocking / juddering gone, as well as the rattle.
I did also get a mechanic to run a diagnostic. That came back clear. No issues there.
I'll still be changing the plugs for piece of mind.
Going forward I'll be checking the oil more regularly...like a diesel engine! 😁
Thank you all for your help.
Great forum... Proud to be in the club!! :) 🙏🏽
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Thanks Gadgee.
Discovered an issue with the oil filter today. Could be the root cause to everything. Going to buy a new filter tomorrow.
Changed spark plugs today. They looked like they needed replacing 😕
The previous owner had the car from new on the Motability scheme, and had it serviced from the main dealer. Although there is a full service history, I suspect they weren't doing everything properly. How does an oil filter come loose? [rhetorical]
Anyway, fingers crossed it'll all come good.
 
1 - 8 of 8 Posts
Top