Ford B-Max Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter · #1 ·
Just had the powertrain warning light come on. Also malfunction warning on the screen. Has anybody else had this problem. Car only six weeks old.
 

·
Registered
Joined
·
637 Posts
Manual says:If either lamp illuminates when the engine
is running, this indicates a malfunction. The
engine will continue to run but it may have
limited power. If it flashes when you are
driving, reduce the speed of your vehicle
immediately. If it continues to flash, avoid
heavy acceleration or deceleration. Have
the system checked by an authorised
dealer immediately.
WARNING
Have this checked immediately.
If both lamps illuminate together, stop your
vehicle as soon as it is safe to do so
(continued use may cause reduced power
and cause the engine to stop). Switch the
ignition off and attempt to restart the
engine. If the engine restarts have the
system checked by an authorised dealer
immediately. When the engine does not
restart have your vehicle checked before
continuing your journey.
 

·
Registered
Joined
·
3 Posts
I have the same problem with a four weeks old B-Max, 1.6 petrol Automatic, less than 500 miles on the display.
What was the fault with your B-Max, Robertdownie? Thank you!Edited by: ChristianeL
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #5 ·
Car is going back into the garage again for the powertrain warning light. Also trying to get the wipers moved,hopefully.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #6 ·
What happens is I get a warning on screan saying malfunction take your car to get serviced. Also an orange cog wheel on the steering cluster. After I switch the engine off for a little while it gou away.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #8 ·
Just got the car back from the garage. They couldn't find the fault in the malfunction notice coming on. They said it could be the software, they are going to contact ford. As for the windscreen wipers they moved the drivers side , it is a lot better. They couldn't do anything about the mpg.
 

·
Registered
Joined
·
3 Posts
I am back from the garage too. The car produces error codes which don't exist. They did a 20 min test drive couldn't find anything, deleted the codes and informed Ford. So far the light didn't come up again.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #10 ·
Hi Christianel. I'm finding a lot of issues with this car. The window wipers leaving a 4 inch strip not cleaned, powertrain light coming on, the petrol flap not being locked,the drivers door needing slammed before it will lock, the mpg being way below what they said it would be. And that's me only had the car 12 weeks. Let's hope these things get sorted. Beginning to have second thoughts ?
 
1 - 10 of 10 Posts
Top