Ford B-Max Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I had a problem where the car would not start, the warning "traction control off" came up and nothing happened.Called GreenFlag and they found I had a battery voltage of 11,2 volts which they said was insufficient to start the engine . A quick charge and away we went. However they said I a parasitic amperage drain
(something was not switching off and so draining the battery overnight). As the car is still under warranty I contacted my local Ford dealer who have never heard of this situation. I have now booked it in for further investigation. Has anyone come across this before and if so what happened?
 

·
Registered
Joined
·
1,102 Posts
Ivecome across it many times. Usually a boot light switch sticking, a courtesy light or a glovebox light. Ive also come across situations where a fault in the radio has been causing it.

Something is draining the battery and a good auto electrician should find it if you cant find it yourself.

Im assuming you have nothing plugged into your 12v sockets or usb socket and that you are not using a satnav or dashcam, phone charger, etc.

It could be ocurring through any electrical curcuit, but an auto electrician will eliminate the most obvious first.Edited by: cianpars
 

·
Registered
Joined
·
132 Posts
Hi boots174, since my similar problem at just over 4000mls. (which is well documented on this site and was caused by the phone sync module) l have suffered NO further battery failure. Having now completed 10.000 mls.
 
1 - 4 of 4 Posts
Top