Ford B-Max Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hello to all, I have just purchased a used 2014 (64) B-Max Zetec. When the car is locked I see no pulsing red (or other colour) light to indicate that the immobiliser is active. Is this the standard on all B-Maxes or should I see a pulsing light and if there is no such light there is something amiss with the system?I have had such lights on my two most recent cars, one a Ford (2005) and the other a Citroen (2005).
 

·
Registered
Joined
·
1,104 Posts
I dont recall seeing a flashing light on mine. Will check later when dark.

You are right though, even my wife's little Kia has one.
 

·
Registered
Joined
·
43 Posts
Evening all, on our 13 1.5tdci zetec B-max there is a pulsing red light coming from just under the digital display below the odometer.

That said it doesn't stand out partly because that bit is slightly recessed.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #7 ·
Cottontop, thank you very much for your reply. It's rather alarming (pun intended!). I've just looked again in my car and still can't see a pulsing light, but the car is standing in full sun so it's very difficult to see any light at the moment. I will check again thoroughly this evening, after dark. I will report the result on Sunday, as I shall be away from my computer tomorrow. Jim
 

·
Registered
Joined
·
1,104 Posts
Hywel S Wales said:
Just checked via the menu system, my car is "Full Guard" protected - even though I can't see a flashing light. as Cottontop says, it may be on but difficult to see !
Ditto
 

·
Registered
Joined
·
54 Posts
JayCee, I don't see a reason to be alarmed about that. If your immobilizer is not working, you wouldn't be able to start the car. The "immobilizer" is not a separate unit blocking your car from starting - it is the hardware/software component integrated into the engine management. When you insert the key, it will communicate with the transponder in the key, and only if the reply from the transponder is satisfactory it will allow to start the ignition and injectors. So it must work 100% properly to be able to start the car.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #11 ·
I've checked after dark and there's no pulsing light. I do wonder about the purpose or function of the small triangular screen below the odometer screen. That's where I would have expected to see the light, if there is one at all. Jim
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #12 ·
Nick, thank you very much for your comprehensive and very instructive replyMy sincere thanks to everyone who has contributed a reply to my original query. You have all helped me very much. JayCee.
 
1 - 16 of 16 Posts
Top