Ford B-Max Forum banner
1 - 20 of 50 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi,hope someone can help!!!!Ive a 2012 B-Max 1.5 TDCi. Problem started April with (ENGINE MALFUCTION SERVICE NOW)with reduced power safe mode kicking in,it came and went a few times so took it to ford who cleaned the fuel filter well that's what they told me.all was good until 5th May when (ENGINE MALFUCTION SERVICE NOW) came on again but this time the orange engine light(management light I think)also came on,reduced power again,I switched car off a few timesbut this timeit didn't reset,limped home and started car next day all warnings were reset,car was fine for less than 2mins only this time no warning lights just reduced power felt like the turbo wasn't kicking in and only running on 3 cylinders(well that's what it felt like from owning older cars)..Took it to ford on the (6th May)who told me to call back in 2 hours so I did but they couldn't find the problem,told me they would phone me at the end of that day. they did to tell me they still cant find fault.and so on Friday still cant find fault,Monday still cant find fault,tue,wed,thur still cant find fault!!!!!Today they said a specialist was calling to have a look???
I have read that it might be EGR valve???I said to guy at ford EGR valve and got laughed at for even suggesting such a thing....(so rude)...
So that's where I at to right now.....
any help would be greatful cheers roy......
 

·
Registered
Joined
·
132 Posts
Hi royster ,There seems to be a problem with the malfunction notice coming on . I've had it come on eight times in the last five months after the third time I took a photo with my phone just In case they did not believe me. I've been on to ford about it and they said there is a software update coming out to fix it, that was three months ago, so don't hold your breath.
Robert Downie.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks Robert,very frustrating.
Ford mechanic drovethe carwhen I first give it to them,and hethought it was a fuel filter...7 days later and a big company like ford still cant find whats wrong with it???
Surley when they hook it up to the diagnostics it would log all faults and if not it should....
thers only 1900 miles on it....lol
 

·
Registered
Joined
·
132 Posts
Hi royster, pop into dealer today to find out if there was any news on an update for the malfunction notice coming on. I new what they were going to say before I asked them. They said no software update in the near future , ford know about the problem and are doing there best to solve it. They are also looking at the blind spot where the wiper stops leaving four inches unwiped. Malfunction notice has now came on nine times, getting a bit wary about taking the car on the motorway in case something happens and I loose power and the power steering. I think I'll contact motability about it.
 

·
Registered
Joined
·
14 Posts
My 2013 b-max 800 miles often says powertrain, service car. I have not told ford yet. I heard of egr valve on old c-maxes, lots of times a few years ago. Engine stalled again today for split second pulling out into traffic, if car had been comeing, disaster or dead?
 

·
Registered
Joined
·
132 Posts
Car is going into the garage on Wednesday for a software update to try and cure the engine malfunction notice coming on. Don't know where this update has come from as they didn't have one on Thursday . Personally I think they are clutching at straws. If they can't solve this I think it will be going back.
 

·
Registered
Joined
·
132 Posts
Took my car to the garage yesterday to get the software update to stop the malfunction notice coming on. Got a phone call two hours later saying car was ready to pickup, unfortunately it was the wrong update. Surprise surprise. Don't think they've got one , they just keep fobbing me off. If it comes on again it will be going back. Shame cause I love the car.
 

·
Registered
Joined
·
2 Posts
Hello, I got the same message yesterday as I started the car on the drive. Switched off and restarted OK. Used it for a short journey OK. If this can happen anytime on the road with a reduction of power then I had better call the dealer. Note- I have done 1700 miles and love the car !!!
 

·
Registered
Joined
·
132 Posts
Hi David, I've now had the update. Got it about three weeks ago. It happened twelve times with me over the five months I've had the car. It's been ok since I've had it done so keeping my fingers crossed its finally sorted. Mine is a 1.6 auto titanium through motability what one have you got?
 

·
Registered
Joined
·
637 Posts
Be prepared that if it is a motability car, the dealer may ask you "have you called out RAC" as they did with me for the same message displayed on the car. They refused to take the car in unless I had a report sheet from RAC. Utterly a waste of time, as the RAC report just states an engine fault that the RAC cannot fix, and you guessed it, they reccomend you speak to the dealership.
 

·
Registered
Joined
·
103 Posts
Hmm same here as well

1.6 powershift zetec auto had the "engine malfunction service now" message as well...spoke to the dealer who were as vague as can be said the car was not safe to drive..then changed her mind and said it was so she's left me non the wiser!

since speaking the message has gone....i'm in the dealer monday at 8am to see whats happened

seems mad on a car thats less than 2wks old


I did however speak to the RAC afterwards they said "oh that old chesnut" you need to speak to the dealer BUT if the message appears again and your not happy ring us back and they'll tow to peoples....wonder what motability say about this all
 

·
Registered
Joined
·
132 Posts
After it happened to me twelve times I got a software update which seems to have helped. It hasn't come on for three weeks. So keeping my fingers crossed its sorted. Are you in people's in falkirk. I was with them but moved to macrae and Dick in Stirling. Tell them there in an update for it.
Robert Downie.
 

·
Registered
Joined
·
637 Posts
Not that it helps matters under this topic, but when all this happened to me, I found RAC could not do more for me, including getting me a hire car, getting it delivered to the dealer (as I would drive the BMAX to the dealer and the hire car home), when they came out to me knowing that I was a motability customer, they even asked me if there were any immediate journeys needed (medical / shopping) while they were here... to which they were prepared to take me to (but not wait for me to come out from understandably).... if only FORD was like that.
.... no.
Edited by: Davis_Zadian
 

·
Registered
Joined
·
103 Posts
well.....after waiting nearly 4hrs at the dealer they diagnosed suprise suprise a software fault...car has been reflashed and hopefully no more worries..hmm we'll see!!

Peoples ford Liverpool...1st visit and already its a nightmare
 

·
Registered
Joined
·
1 Posts
This sounds familiar. I have had the same experience today with my 4 week old BMax 1.4 petrol Zetec. The instrumentation showed Engine Malfunction . Service now and orange spanner lit. The power of the vehicle fell dramatically. I called the Dealer who told me to phone ford assist who sent out the AA. The warning had miraculously disappeared and no fault was logged therefore the AA patrol could do nothing. The fault reoccurred later in the day after only 14 miles! Dealer has now agreed to investigate the fault but it would be helpful to know if this is a common occurrence of the BMax. Not impressed!
 

·
Registered
Joined
·
132 Posts
Yes giddylimit,this happened with me 12 times. I didn't lose power,but it was quite scary . They eventually found an update for it and it hasn't happened since. So hope you get things sorted soon.
RobertDownie.
 

·
Registered
Joined
·
1 Posts
Hello guys,

First post, and it's already in the malfunction topic :(
Just a quick presentation, I am a B-max owner, 1.0 ecoboost, with 8000 kms on the clock, living in Brussels (Belgium).


Yesterday when coming home got the engine malfunction message and loss of power, like I had one cylinder failing. The service light went on and I turned off the car. Turned on again, all was normal. Went home and today decided to take-it to the Ford Garage.


Before I left home I've googled the issue and got people saying they had the same, but could not prove-it to the dealership. With this in mind I've decided to put a camera on my car to catch the issue!
GOT IT TWICE :)
Spoke with the salesman (technical service is closed on Saturday) who asked me to bring the car Monday morning. He told me it was safe to drive the car but I've decided to keep it home for the weekend.


Here is the video from this morning, hope it help other b-max owners as it appears to be a recurring issue;http://youtu.be/hXMViyATcEA
 

·
Registered
Joined
·
4 Posts
My wife got the same thing today ENGINE MALFUNCTION SERVICE NOW (Sat 21/9/13) just 900 miles on the clock.Only a salesman available at Ford who advises RAC call out because he says he is not mechanically minded (Yet he works for Ford).
I have had Mazda for 40years until this month without ever having a problem.
I will be queuing at Mazda Garage first thing Monday morning and will not be troubling Ford again.
 
1 - 20 of 50 Posts
Top