Ford B-Max Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a b max from 2015. Engine malfunction light came on. Took the car to a friend of mine, who hooked it up to the computer. The car was reporting airmass sensor fault. I've changed the sensor and tried resetting the car, but the engine malfunction warning comes on straight away, still reporting same problem. Any thoughts anyone????
 

·
Registered
Joined
·
453 Posts
could be the wiring to the sensor, try cleaning the connector.

when you say, 'resetting the car' what do you mean? (disconnect battery for an hour?) or clearing the fault codes?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Connectors look fine! By resetting, I mean deleting fault codes. A friend of mine, who is a mechanic, told me, it might be the wiring. In that case, I probably need to get a hold of a wiring diagram. It might be worth mentioning that the ""city engine start/stop""� function is no longer avalible. The engne is stuck in safety mode ˜«
Is it safe to rule out any fuses or relays being faulty?Edited by: Herik
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
first sensor was orgigianl. I replaced it with an unoriginal one. The OBD-II shows no reading from the sensor. Tried disconnecting it while car was running, nothing happended. Is it possible to buy a wiring diagram on the internet?
 

·
Registered
Joined
·
311 Posts
Herik said:
first sensor was orgigianl. I replaced it with an unoriginal one. The OBD-II shows no reading from the sensor. Tried disconnecting it while car was running, nothing happended. Is it possible to buy a wiring diagram on the internet?
I only ask, as when a sensor failed on an Accord I owned, only a genuine sensor would stop the fault light coming on.
 
1 - 9 of 9 Posts
Top