Ford B-Max Forum banner
Club Information

Club Information

Contacts, Stickers, Help & Advice
183
102K
183
102K

Club Discounts

Discounts only available to members (Min 20 posts required)
37
15.8K
37
15.8K
General Message Area

Newbies

Hi and Welcome! Introduce yourself here......
3.4K
1.1M
3.4K
1.1M

Main Message Centre

Anything Ford B-Max related
4.7K
1.8M
4.7K
1.8M

Ordering

All pre-orders, ordering, delivery info here
354
126K
354
126K

Gallery

Post pictures of your B-Max here!
655
224K
655
224K

Technical

Faults and technical problems
5.9K
2.7M
5.9K
2.7M
Classifieds

For Sale & Wanted

Sell & buy B-Max related items
215
98.6K
215
98.6K
Vendor Member Section Want to Grow Your Business? Learn more about becoming a Supporting or Premium Vendor

Vendor Deals

Find the latest deals from our exclusive vendors.
0
0
N/A
0
0
N/A
Forum Support

Site News

News from bmaownersclub.co.uk
3
909
3
909

Site Help and Feedback

Where you can post your site related issues.
55
51.3K
55
51.3K
Off Topic Lounge

Idle Chit Chat

Non Ford B-Max related topics... Have a look inside!
857
252K
857
252K
Latest Posts See all new posts
  1. Main Message Centre
    Hi all I have just checked to see if I require an update on sync, it says it is I have downloaded the file, I'm a bit apprehensive in installing incase it messes every thing up, any advice will be appreciated
  2. Hi there! I drive a 63 plate 1.4 litre B Max with 58K miles on the clock. I have just had a letter from my local garage that does my MOT etc advising that my car is now due a cambelt change. Are they just being over-diligent or is a cambelt change really required at this stage? I have just...
  3. Technical
    hi all........had a problem with my stereo..it suddenly cut of and started making screeching sound from left speaker.....it did this even though i turned off the radio.it did this for ten minutes untill i eventually had to turn car off completely..on restart everything back to normal...anyone...
  4. Hi all. When I start the engine sync automatically looks like it's dialling my mobile even though it isn't and I can't use the phone buttons on the steering to stop it. I have to "forget this device" on my iPhone but when I start the engine next time it does it again. Wonder if anyone can help? TIA
  5. Technical
    Having had my 2014 Bmax serviced(92000 miles) I noticed as soon as I travelled a short distance a message on my display read "Engine Service Required" and to OK it, which I did and the message disappeared.However another thing I noticed was a spanner symbol was showing also and this continued to...
See all new posts
Top