Ford B-Max Forum - Reply to Topic
Thread: Low beam bulbs Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford B-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
29th August 2019 20:00
chipsdigme
Quote:
Originally Posted by Drg1981 View Post
Hi looking for a bit of advice I have a 65 plate B-max and the low beam light bulbs have stopped working, I have replaced both bulbs and still the same can anyone give me any advice on this please.
I have this exact same issue. I noticed the other day they weren't working. I haven't changed the bulb yet or tried tripping anything. Weird we have the same fault, mine's 14 plate diesel.
26th August 2019 14:20
cianpars Sounds like a job for an auto electrician or the main dealer then.
25th August 2019 12:41
Drg1981 Thanks for the feedback guys, all fuses are fine disconnected the battery and still no joys
17th August 2019 21:11
pegleg There are no fuses for dip beam. The bulbs are controlled by the BCM, possibly a smart/temp FET.
You could try disconnecting the battery for a few minutes.
16th August 2019 08:29
Drg1981 Thanks guys ill check out the fuses.
15th August 2019 21:46
cianpars That was my first thought Gremlin. I've had bulbs breaking fuses once or twice, but surely they don't put both headlamps on the same fuse, do they?
15th August 2019 21:17
Gremlin sounds like a fuse problem, (possibly a relay) but check the fuse first.

ps fuses can blow when a bulb blows, unusual, but not uncommon.
15th August 2019 18:10
Drg1981
Low beam bulbs

Hi looking for a bit of advice I have a 65 plate B-max and the low beam light bulbs have stopped working, I have replaced both bulbs and still the same can anyone give me any advice on this please.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome