Ford B-Max Forum - Reply to Topic
Thread: Brake fade problems Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Ford B-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
23rd November 2020 19:51
pegleg Any update with this?Im puzzled as to why just changing the discs and pads makes the pedal soft; sometimes very slightly spongy until bedded in.
When you start the engine with foot on the brake pedal, the pedal will go down due to the vacuum effect.
20th November 2020 16:30
prestoni Hi there, thanks very much for responding. Yes when I picked the car up the first time I had to pump the brakes occasionally to ensure I could stop. Since then they have done a full brake fluid change and bled the brakes and did it again after they fitted the master cylinder. They did say to me that there is still air bleeding out of the system and still it hasn't changed anything. They have also checked all the brake lines and seals and said all is fine. They think it could be something to do with the vacuum system but I don't know what that means. I am still can't see how such an easy job is causing so many issues. I still don't have the car back to check how it drives and if indeed it can be driven.
20th November 2020 12:29
cianpars Do you find pumping the brakes while slowing down makes the pedal harder? If so, I wonder if they bled the system properly after they fitted the disks.
20th November 2020 11:43
prestoni
Brake fade problems

Hi there, I am new to the site. I have had our BMax for 7 years and despite having water ingress into the boot which was caused by a displaced overflow pipe under the fuel filler it has been really good until now as it has been flexible for what we need a car for.

The car failed its MoT about 3 weeks ago on warped discs so I agreed with the MoT station to change the discs and pads. As you would expect this should have been an easy job. Before the MoT the brakes were excellent with feel and confidence. Since the changing the discs and pads, the pedal is soft when driving. When stationary the pedal is firm but as soon as the car is started the pedal is mush. The guys suggested it was the master cylinder but I have never had one go as immediate as that. It turns out after changing the master cylinder the problem still exists.

Has anyone else had this experience? I am told it could be a vacuum problem and they are checking it over. The car has been in the garage for 3 days and still I am no further forward.

I look forward to hearing from anyone out there that could help.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome