Light fault - Ford B-Max Forum
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 28th January 2020, 20:48 Thread Starter
Junior Member
 
notyes's Avatar
 
Join Date: Jan 2020
Location: Hungary
Posts: 2
Light fault

Hey There Fellow B-Max owners!

Combined break/tail light on a 2015 B-Max seem to have an issue. Tail light is OK, but break light does not light up. Any suggestions on how to fix it?
Is it possible that a light bulb works OK as tail light but not as break?

notyes
notyes is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 29th January 2020, 01:18
Senior Member
 
Join Date: Oct 2016
Location: Bristol
Posts: 998
Stop and tail light is a single bulb and one of your filaments is gone. Just replace the bulb. It's a standard bulb btw.

B Max Titanium X 1.0 125 bhp in Magnetic with built in SatNav and rear sensors.
cianpars is offline  
post #3 of 3 (permalink) Old 29th January 2020, 01:23
Senior Member
 
Join Date: Oct 2016
Location: Bristol
Posts: 998
Also, the manual is incorrect. There are a couple of threads on here which give you the corect procedure.

You remove the cluster by removing a nut in the boot behind it and replace the bulb. It's a bit fiddly and tight as ****, but not difficult so long as you have strong hands. I has to wrap mine in a piece of cotton to get a firmer grip, but it's not difficult.

B Max Titanium X 1.0 125 bhp in Magnetic with built in SatNav and rear sensors.
cianpars is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford B-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome