Power washed car, now it won’t start. - Ford B-Max Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 4th January 2020, 19:56 Thread Starter
Junior Member
 
Join Date: Jan 2020
Posts: 1
Power washed car, now it won’t start.

Hello! Thank you for letting me join the forum. Today I power washed my B Max. Went to start the car and it’s not turning over. All the instrumentation lights up and there seems to be a clicking noise coming from the engine. Could I have got something wet? I’ve lifted the bonnet...there are some droplets of water on things but the battery connections and fuse box are dry.
Lissyloo75 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 4th January 2020, 23:30
Senior Member
 
Join Date: Oct 2016
Location: Bristol
Posts: 991
Sounds like a flat battery, not unusual at this time of year. Pressure wash may be just coincidental.

See what happens after an overnight trickle charge.

B Max Titanium X 1.0 125 bhp in Magnetic with built in SatNav and rear sensors.
cianpars is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford B-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome