Engine Light, car dragging, but then goes away - Ford B-Max Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 27th April 2019, 14:03 Thread Starter
Junior Member
 
Join Date: Apr 2019
Location: Blackburn, Lancashire
Posts: 1
Unhappy Engine Light, car dragging, but then goes away

The last few months, my '13 reg B-Max (Maximum B*stard as I like to call him!) have given me numerous trips to the garage as my engine light will come on, and the car feels like its dragging, and then when I stop and start it up again, it's absolutely fine! The diagnostics are showing that it is a Turbo Boost issue but there is no issue showing when the checks are performed. Has anyone else had this issue and could give me some insight as to what to try?

Love from a working mum who needs Maximum to behave because her job and baby relies on it!!!
<3
J_L_F is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 28th April 2019, 07:57
Senior Member
 
Join Date: Nov 2017
Posts: 261
Is it a Ford main dealer you've been to ?
Hadrian1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford B-Max Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome